$re = '/((.*?)(\(\w{1,}\)))((.*?)(\g<3>))*/m';
$str = 'Geese (Flock) Dogs (Pack)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);