re = /((.*?)(\(\w{1,}\)))((.*)(\g<3>))*/m
str = 'Geese (Flock) Dogs (Pack) Elephants (Herd)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end