$re = '/^.*?:\s\K.*/';
$str = 'date: march 27, 2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);