import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|(?:\\p{L}+\\P{L}+){1,3})(p[oó][zž][ií][cč][ií])($|(?:\\P{L}+\\p{L}+){1,3})";
final String string = "Ahoj,\n\n"
+ "potřebuji najít pozici slova v textu (a pak ukázat kousek textu před a po, resp víc slov hledám, ale pro demonstraci, stačí 1 slovo).\n\n"
+ "Mám tedy nějaká text, zkusím vyhledat třeba slovo „Richter“ (potřebuji aby to umělo s diakritikou i bez), takže jsem použil regexp a zjištuju kde je zase problém.\n\n"
+ " funkce strpos samozřejmě nefunguje dobře (díky multi-byte kódování ukáže jinou pozici než by měla)\n"
+ " funkce mb_strpos se zachová správně (kdo by to byl čekal ;-))\n"
+ " preg_match_all se chová stejně „hloupě“ jako strpos\n"
+ " našel jsem v komentářích starou funkci upravenou o „MB“ chování a ta funguje dobře (jako mb_strpos) více na php.net (https://www.php.net/…atch-all.php#…)\n"
+ " vyzkoušel jsem si matchAll z balíčku Strings a funguje stejně špatně jako preg_match_All\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}