$re = '/[^\r\n.]+\.[^\r\n.]+\.([0-9]{3})/m';
$str = 'ABC.123.99XX
ABC.123.456XX
ABCOUOU.123123123.000871XX
ABCanything_else.123123123.111871XX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);