const regex = /^(?:([A-Z\d])(?!.*\1)){5,20}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([A-Z\\d])(?!.*\\1)){5,20}$', 'gmi')
const str = `Z1234aZ
aVBNa1
ZXCVB123
12zv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}