$re = '/[\d\w]+/m';
$str = '12,test,hallo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);