$re = '/(?<!\\\\)(?:\\\\.)*\((?:\\\\.|[^:)\\\\])*:(?:\\\\.|[^:)\\\\])*\)/';
$str = 'yo (p:abc-123-def) meets \\(p:2) \\(in the cinema\\) \\\\ (p:3) (p:4\\) won\'t
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);