re = /(?:[^\\]|^)((?:\\.)*\((?:\\.|[^:)\\])*:(?:\\.|[^:)\\])*\))/
str = 'yo (p:abc-123-def) meets \\(p:2) \\(in the cinema\\) \\\\ (p:3) (p:4\\) won\'t
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end