$re = '~(?:-(\pL+)){2}:[^;]+;~m';
$str = 'background: -o-linear-gradient(bottom, rgba(0, 0, 0, 0.45), transparent 47%);
display: -webkit-box;
line-height: -moz-block-height;
-webkit-transform: translateY(100%);
-moz-transform: translateY(100%);
-o-transform: translateY(100%);
.header-top-panel:before, .header-top-panel:after {
content: " ";
display: table;
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;