import re
regex = re.compile(r"^(AllowUsers.*) (\bbob\b) ?(.*)$", flags=re.MULTILINE)
test_str = ("AllowUsers richard\n"
"AllowUsers richard jeremy\n"
"AllowUsers james richard jeremy\n"
"AllowUsers jeremy\n"
"AllowUsers bob\n"
"AllowUsers bob billybob\n"
"AllowUsers billybob bob\n"
"AllowUsers billybob steve bob eric bobby\n"
"AllowUsers billybob bobby steve bob eric\n"
"AllowUsers richard bob\n"
"AllowUsers richard bob jeremy\n"
"AllowUsers bob james richard jeremy\n"
"AllowUsers bob jeremy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")