#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)val"":\x20?"".*?(?<Dex1>.*)|description"":\x20?""(?<Dex2>.*)|""text"":\x20?""(?<Dex3>.*)"
Local $sString = "[{" & @CRLF & _
" "latestID": 166," & @CRLF & _
" "parent": "story_chapter_5_40_rival"," & @CRLF & _
" "type": "dialogue"," & @CRLF & _
" "id": "story_chapter_5_41_rival"," & @CRLF & _
" "location": "black"," & @CRLF & _
" "music": "default"," & @CRLF & _
" "random": false," & @CRLF & _
" "conditions": []," & @CRLF & _
" "val": "The girls are disappointed that we don't have more fans. Additionally, you haven't got enough [color:red]Advancement Points</color> yet."," & @CRLF & _
" "description": "[actor_0] has been suspended from school for lewd behavior. Apparently, she decided not to wear panties and then flashed her history teacher. When asked about it, she said the look on the face of \"that stuffy old crone\" was priceless, and getting suspended was worth it. \n\nDespite the rather entertaining nature of the story, [actor_0] shouldn't get into a habit of behaving recklessly and thinking there won't ever be consequences. It might make sense to further discipline her, especially since she doens't seem to be taking her suspension very seriously.\n\nOn the other hand, if you leaked this story online, getting kicked out of school is often seen as \"cool\" and might increase her popularity with rebel type fans. \n\nWhat will you do?"," & @CRLF & _
"" & @CRLF & _
" "actors": []," & @CRLF & _
" "setup": [{" & @CRLF & _
" "val": "Hello, [player:SirMaam]! Welcome to the [color:red]Ero Events</color> status tracker."," & @CRLF & _
"" & @CRLF & _
" "tag": "story_rival"," & @CRLF & _
" "posX": 0," & @CRLF & _
" "facing": "default"," & @CRLF & _
" "startHidden": true" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "scene_params": []," & @CRLF & _
" "script": [null, null, {" & @CRLF & _
" "id": 0," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "Ah. [player:polite]. So glad you could join me."," & @CRLF & _
" "effect": [{" & @CRLF & _
" "target": "meta"," & @CRLF & _
" "parameter": "set_cg"," & @CRLF & _
" "formula": "ramen_m_m ramen_m_f ramen_f_m ramen_f_f"" & @CRLF & _
" }, {" & @CRLF & _
" "target": "audio"," & @CRLF & _
" "parameter": "music"," & @CRLF & _
" "formula": "retro_cafe_theme"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []," & @CRLF & _
" "vo": "RivalM_048_Greeting6"" & @CRLF & _
" }, {" & @CRLF & _
" "id": 1," & @CRLF & _
" "type": "choice"," & @CRLF & _
" "actor": null," & @CRLF & _
" "val": "What big secret are you hiding?"," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": [{" & @CRLF & _
" "id": 2," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "Straight to business, eh? Let's get right to it, then."," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []," & @CRLF & _
" "vo": "RivalM_013_Fun1"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" }, {" & @CRLF & _
" "id": 3," & @CRLF & _
" "script": []" & @CRLF & _
" }, {" & @CRLF & _
" "id": 10," & @CRLF & _
" "type": "choice"," & @CRLF & _
" "actor": null," & @CRLF & _
" "val": "Phantasm Facade"," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []" & @CRLF & _
" }, {" & @CRLF & _
" "id": 11," & @CRLF & _
" "type": "choice"," & @CRLF & _
" "actor": null," & @CRLF & _
" "val": "Both [rival_group] and Phantasm Facade"," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []" & @CRLF & _
" }, {" & @CRLF & _
" "id": 12," & @CRLF & _
" "type": "choice"," & @CRLF & _
" "actor": null," & @CRLF & _
" "val": "I don't know"," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []" & @CRLF & _
" }, {" & @CRLF & _
" "id": 13," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "Yes. It was difficult for me to move all of the pieces into place, but Phantasm Facade was selected as part of the final group selection."," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []," & @CRLF & _
" "vo": "RivalM_014_Fun2"" & @CRLF & _
" }, {" & @CRLF & _
" "id": 14," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "The most difficult part was finding a way to get Phantasm Facade through the process without ever exposing myself as the mastermind behind it."," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []" & @CRLF & _
" }, {" & @CRLF & _
" "id": 15," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "The group itself is tied to a shell corporation that I created through a law firm that serves intermediary to protect my anonymity, but the final interview round was a bit of an unexpected curveball."," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []" & @CRLF & _
" }, {" & @CRLF & _
" "id": 16," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "I had debated whether to hire an actor to represent the group before the answer smacked me in the face:"," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []," & @CRLF & _
" "vo": "RivalM_037_Worried3"" & @CRLF & _
" }, {" & @CRLF & _
" "id": 17," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "I had one of the idols from the group go to the interview and pose as the manager."," & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []," & @CRLF & _
" "vo": "RivalM_014_Fun2"" & @CRLF & _
" }, {" & @CRLF & _
" "id": 18," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "They're all talented performers, and getting through that interview was just one last performance."," & @CRLF & _
" "description": "You spend some time talking through the issue with [actor_0:full]. You point out that the discomfort she's going through now is definitely unpleasant, but it will pay off in the future. \n\nSeeing this as a opportunity to overcome an obstacle rather than being a victim helps empower her, and [actor_0] feels more able to deal with the situation. She thanks you for taking the time to talk with her. \n\nOver the next week, her newfound tenacity earns her respect among the other students and the bullying attempts graually subside."," & @CRLF & _
" "text": "did you see [actor_0] in this month's issue?"" & @CRLF & _
" "text": "I gotta say, [actor_0] being \"all natural\" is an understatement"" & @CRLF & _
" "val": "I'm sure that's it. So don't stress about this. What you should be doing is imagining what kind of suit <blue>Kiyomi</color> received. I bet it's something totally lewd!"" & @CRLF & _
" "val": "Merry Christmas, [girl1]. (END)"," & @CRLF & _
"" & @CRLF & _
" "description": "You spend some time talking through the issue with [actor_0:full]. You point out that the discomfort she's going through now is definitely unpleasant, but it will pay off in the future. \n\nSeeing this as a opportunity to overcome an obstacle rather than being a victim helps empower her, and [actor_0] feels more able to deal with the situation. She thanks you for taking the time to talk with her. \n\nOver the next week, her newfound tenacity earns her respect among the other students and the bullying attempts graually subside."," & @CRLF & _
" "description": "Some obsessive fans have discovered that [actor_0:full]'s mother has an OnlyFans account with nude photos. The news has spread through the fanbase rapidly, and there are a lot of conflicting voices and opinions. \n\nSome fans are supportive of both [actor_0] and her mother. Others are critical of her mother but still supportive of [actor_0]. And still others condemn them both. \n\n[actor_0] is understandably distraught and unsure how to handle the growing drama. She's asking for your advice on how to respond."," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" }, {" & @CRLF & _
" "poster": "F_HC_YA"," & @CRLF & _
" "text": "Incredible! I wish I looked as good as her when I'm exercising!"" & @CRLF & _
"" & @CRLF & _
" "effect": []," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []" & @CRLF & _
" }, {" & @CRLF & _
" "id": 19," & @CRLF & _
" "val": "(Spend 1 Influence) *Convince her to take more clothing risks*"," & @CRLF & _
" "val": "I have to go... (END)"," & @CRLF & _
"" & @CRLF & _
" "type": "message"," & @CRLF & _
" "val": "You dutifully turn around while [girl2:casual] undresses and puts on the swimsuit."," & @CRLF & _
" "val": ""," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "In short, I have two groups in the running, competing against each other, and the committee members are none the wiser."," & @CRLF & _
" "val": "Ah! [player:SirMaam], I didn't expect you to be so forward."," & @CRLF & _
" "val": "(Spend 1 Influence) *Convince her to take more clothing risks*"," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" "effect": [{" & @CRLF & _
" "target": "story_rival"," & @CRLF & _
" "parameter": "popup_left"," & @CRLF & _
" "formula": "default smug sparkle none"" & @CRLF & _
" "val": "Hello, [player:SirMaam]! Welcome to the [color:red]Ero Events</color> status tracker."," & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "requirements": []," & @CRLF & _
" "script": []," & @CRLF & _
" "vo": "RivalM_034_Shocked3"" & @CRLF & _
" }, {" & @CRLF & _
" "id": 20," & @CRLF & _
" "type": "message"," & @CRLF & _
" "actor": "story_rival"," & @CRLF & _
" "val": "Phantasm Facade is, of course, too avant garde to be selected as the primary."," & @CRLF & _
" "effect": [],"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")