#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![A-Z0-9])(?=[A-Z0-9]{10}(?:[^A-Z0-9]|$))([^0]*0*(?=(?:[^A-Z0-9]|$)))"
Local $sString = "ABC1000000 - valid" & @CRLF & _
"3212130000 - valid" & @CRLF & _
"0000000000 - valid" & @CRLF & _
"ABC1000100 - invalid" & @CRLF & _
"0001000000 - invalid" & @CRLF & _
"0000" & @CRLF & _
"0 0000000000" & @CRLF & _
"00000000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")