import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<timestamp>\\d+-\\d+-\\d+T\\d+:\\d+:\\d+\\.\\d+([+-])\\d+:\\d+)\\s+\\[(?<severity>\\w+)\\](?<message>.*(?:\\n(?!\\d+-\\d+-\\d+T).*)*)$";
final String string = "2022-06-27T15:22:35.506+00:00 [Info] MSAT starting with 60000 tick ...\n"
+ "2022-06-27T15:22:35.506+00:00 [Info] pram[:9999] starting ...\n"
+ "2022-06-27T15:22:35.508+00:00 [Info] New settings received: \n"
+ "{\"indexer.settings.compaction.days_of_week\":\"Sunday,Monday,Tuesday,Wednesday,Thursday,Friday,Saturday\",\"indexer.settings.compaction.interval\":\"00:00,00:00\",\"indexer.settings.compaction.compaction_mode\":\"circular\",\"indexer.settings.log_level\":\"info\",\"indexer.settings.persisted_snapshot.interval\":5000,\"indexer.settings.compaction.min_frag\":30,\"indexer.settings.inmemory_snapshot.interval\":200,\"indexer.settings.max_cpu_percent\":0,\"indexer.settings.storage_mode\":\"forestdb\",\"indexer.settings.recovery.max_rollbacks\":5,\"indexer.settings.memory_quota\":1073741824,\"indexer.settings.compaction.abort_exceed_interval\":false}\n"
+ "2022-06-27T15:22:35.508+00:00 [Info] PROJ[:9999] settings notifier from metakv\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}