re = /(^(test)?_)|((T|t)ests$)/m
str = 'RoundConserved
UtilsTests
utilstests
test_foo_bar_bar
_test
test_something_tests
_Utils
Test_Foo
test_Foo
UtilsTests
test_function_name
_foo
my_tests'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end