import re
regex = re.compile(r"""
(?>[^;]*;){5}(?>[^,]*,){2}\s*[^,^\s]*\s*([^,^;]*)(?>[^;^\r^\n]*)
""", flags=re.VERBOSE)
test_str = "2009311179;2723088770;Комсомольское отделение филиала ПАО \"ДЭК\"-\"Хабаровскэнергосбыт\";2018-10-23;0de159ee-ebc3-4a1e-81ca-63d8fe5a8558;1093163;Хабаровский край, Солнечный район, п. Хурмули, ул. Школьная, д. 20;;Солнечный;;;421;;Школьная;529;20;;;7;1;16;2012-08-01;65,1;41,3;2012-08-01;3;1;12DEC0701E80601161;;2012-08-01;;Капарушкин;Виталий;Викторович;;;4;4;;2012-08-01"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")