# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(GET)\s(.+)\s(HTTP\/\d+\.\d+)\n(Host):\s(.+)$\n(Cache-Control):\s(.+)$\n(Postman-Token):\s(.+)$"
test_str = ("GET /v1/search?q=bob%20dylan&type=artist HTTP/1.1\n"
"Host: api.spotify.com\n"
"Cache-Control: no-cache\n"
"Postman-Token: e2f09f98-f")
subst = "{ headers: \\n\\t{ $4 '$5',\\n\\t '$6': '$7',\\n\\t '$8': '$9'\\n\\t}, \\n\\tverb: '$1',\\n\\tpath: '$2',\\n\\tprotocol: '$3'\\n}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.