re = /{{([^0-9]\w+)/
str = '{{text}}=={{q113=="t123" ? "Active Product":" InActive"}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end