re = /(^\w+\])|(\[\w+$)/m
str = 'text [option1/option2] text
text] [option1/option2] more text
text [option1/option2] [text
text] [option1/option2] [text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end