package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][]*]|.`)
var str = `ABCDE[NOT]FGH
CCGF[NOT]HI
MPJ[NOT]L
MNA[NOT]PLJKAJSHD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}