#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)([+0]?[06]?)(?&sep)(36)?(?&sep)(?P<aera>1|[2-9][0-9])(?&sep)(?P<num>\d{3})(?&sep)(\d{2})(?'sep'[\)\(-\/\.x ]*){2}"
Local $sString = "+36 20 800 8848 " & @CRLF & _
"36 1 267-5260 " & @CRLF & _
"+36 1 267 5260" & @CRLF & _
"+36 24 415 351" & @CRLF & _
"06 (24) 415 351" & @CRLF & _
"6(1)415 3510" & @CRLF & _
"00361-267-5260" & @CRLF & _
"0036-1-267-5260" & @CRLF & _
"0036-1-267-52-60" & @CRLF & _
"208008848" & @CRLF & _
"20800 88-48" & @CRLF & _
"00 34 800 828" & @CRLF & _
"((06)|[\+0]{0,2}\s*36)" & @CRLF & _
"[+0]{0,2}(?&sep)36"
Local $sSubst = "$3$4$5$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)