package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^\h]*[\h]){2}(?<image>[^\v]*)$`)
var str = `This is myimage`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}