$re = '/(\w+)(?=(?:(?!\1).)*\b(\1)\b)/';
$str = 'abc some word abc eee word abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);