package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+) классе\D+(\d+) см`)
var str = `Миша учится в 3 классе, его рост 150 см.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}