$re = '/CN=(?<commonName>[^\,]+)\,.*?(?<!\\\\)\,\s*OU=(?<location>.*?(?<!\\\\))\,\s*OU=.*?\,DC/m';
$str = 'CN=AVB6F9974,OU=Farley PC\'s, OU=Kansas City, OU=Workstations,DC=lop,DC=local
CN=AVB6F9975,OU=Booth PC\'s, OU=Scott Building, OU=Workstations,DC=lop,DC=local
CN=KBOD6F9975,OU=Booth PC\'s, OU=Zale Building, OU=Workstations,DC=lop,DC=local
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);