re = /\b((?!(quick brown|lazy)\b).)+/i
str = 'The quick brown fox jumped over the lazy dog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end