package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]{2,3}$`)
var str = `test
toto
a
ok
top
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}