package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?Exception.*(?:\R+^\s*at .*)+`)
var str = `
Save New Duplicate & Edit Just Text Twitter
---- Minecraft Crash Report ----
WARNING: coremods are present:
TransformerLoader (OpenComputers-MC1.12.2-1.7.5.192.jar)
FMLModule (mdxlib-3.0.0.26 (1).jar)
MovingWorldCore (movingworld-1.12-6.353-full.jar)
MicdoodlePlugin (MicdoodleCore-1.12.2-4.0.2.280.jar)
XaeroWorldMapPlugin (XaerosWorldMap_1.11.0_Forge_1.12.jar)
CXLibraryCore (cxlibrary-1.12.1-1.6.1.jar)
LucraftCoreCoreMod (LucraftCore-1.12.2-2.4.10 (1).jar)
HCASM (HammerLib-1.12.2-2.0.6.19.jar)
iceandfire (iceandfire-1.9.1-1.12.2.jar)
CTMCorePlugin (CTM-MC1.12.2-1.0.2.31.jar)
Plugin (NotEnoughIDs-1.5.4.4.jar)
llibrary (llibrary-core-1.0.11-1.12.2.jar)
AstralCore (astralsorcery-1.12.2-1.10.27.jar)
TheBetweenlandsLoadingPlugin (TheBetweenlands-3.6.2-core.jar)
Do not report to Forge! (If you haven't disabled the FoamFix coremod, try disabling it in the config! Note that this bit of text will still appear.) (foamfix-0.10.10-1.12.2.jar)
MixinLoaderForge (ValkyrienSkies-1.12.2-1.0-alpha-1.jar)
Techguns Core (techguns-1.12.2-2.0.2.0_pre3.2.jar)
CorePlugin (AcademyCraft-1.1.3.jar)
MalisisCorePlugin (malisiscore-1.12.2-6.5.1.jar)
SurgeLoadingPlugin (Surge-1.12.2-2.0.77.jar)
XaeroMinimapPlugin (Xaeros_Minimap_20.27.2_Forge_1.12.jar)
GSHooksLoader (GalaxySpace-1.12.2-2.0.14 (2).jar)
Contact their authors BEFORE contacting forge
// There are four lights!
Time: 11/18/20 10:20 AM
Description: There was a severe problem during mod loading that has caused the game to fail
net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from Extra Planets (extraplanets)
Caused by: java.lang.RuntimeException: You have a double version of the same space station, station for planet ID: -31 You will most likely fix this by checking out compatibility guide over at https://docs.mjrlegends.com/ExtraPlanets/1.12.2compact/
at com.mjr.extraplanets.util.GCRecipeUtilities.addSpaceStationRecipe(GCRecipeUtilities.java:20)
at com.mjr.extraplanets.recipes.ExtraPlanets_Recipes.registerSatellitesRecipes(ExtraPlanets_Recipes.java:331)
at com.mjr.extraplanets.recipes.ExtraPlanets_Recipes.initOther(ExtraPlanets_Recipes.java:33)
at com.mjr.extraplanets.ExtraPlanets.init(ExtraPlanets.java:252)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:637)
at sun.reflect.GeneratedMethodAccessor9.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
at com.google.common.eventbus.EventBus.post(EventBus.java:217)
at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:219)
at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:197)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
at com.google.common.eventbus.EventBus.post(EventBus.java:217)
at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:136)
at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:749)
at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:336)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:535)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
at net.minecraft.client.main.Main.main(SourceFile:123)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- System Details --
Details:
Minecraft Version: 1.12.2
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_51, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 1317339864 bytes (1256 MB) / 6811549696 bytes (6496 MB) up to 32212254720 bytes (30720 MB)
JVM Flags: 8 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx30G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP 9.42 Powered by Forge 14.23.5.2854 Optifine OptiFine_1.12.2_HD_U_F5 117 mods loaded, 117 mods active
States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
| State | ID | Version | Source | Signature |
|:----- |:-------------------------------------------- |:----------------------- |:----------------------------------------------- |:---------------------------------------- |
| LCHI | minecraft | 1.12.2 | minecraft.jar | None |
| LCHI | mcp | 9.42 | minecraft.jar | None |
| LCHI | FML | 8.0.99.99 | forge-1.12.2-14.23.5.2854.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |
| LCHI | forge | 14.23.5.2854 | forge-1.12.2-14.23.5.2854.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |
| LCHI | LambdaLib|Core | 0.2.0 | minecraft.jar | None |
| LCHI | micdoodlecore | | minecraft.jar | None |
| LCHI | xaerominimap_core | 1.12.2-1.0 | minecraft.jar | None |
| LCHI | xaeroworldmap_core | 1.12.2-1.0 | minecraft.jar | None |
| LCHI | com.elytradev.movingworld.common.asm.coremod | | minecraft.jar | None |
| LCHI | foamfixcore | 7.7.4 | minecraft.jar | None |
| LCHI | opencomputers|core | 1.7.5.192 | minecraft.jar | None |
| LCHI | techguns_core | 1.12.2-1.0 | minecraft.jar | None |
| LCHI | damageindicatorsmod | 1.0 | [1.12.2]DamageIndicatorsMod-3.5.1.jar | None |
| LCHI | lambdalib2 | 0.2.0 | AcademyCraft-1.1.3.jar | None |
| LCHI | academy | 1.1.3 | AcademyCraft-1.1.3.jar | None |
| LCHI | aether_legacy | 1.4.4 | aether_legacy-1.12.2-v1.4.4.jar | None |
| LCHI | baubles | 1.5.2 | Baubles-1.12-1.5.2.jar | None |
| LCHI | jei | 4.16.1.301 | jei_1.12.2-4.16.1.301.jar | None |
| LCHI | ebwizardry | 4.3.1 | ElectroblobsWizardry-4.3.1-MC1.12.2.jar | None |
| LCHI | ancientspellcraft | 1.1.0 | AncientSpellcraft-1.1.0.jar | None |
| LCHI | aoa3 | 3.3.6 | AoA3-3.3.6.jar | 8bddeac148843f40e0b9f69201be2f4b3071700d |
| LCHI | galacticraftcore | 4.0.2.280 | GalacticraftCore-1.12.2-4.0.2.280.jar | None |
| LCHI | galacticraftplanets | 4.0.2.280 | Galacticraft-Planets-1.12.2-4.0.2.280.jar | None |
| LCHI | asmodeuscore | 0.0.20 | AsmodeusCore-1.12.2-0.0.20.jar | None |
| LCHI | astralsorcery | 1.10.27 | astralsorcery-1.12.2-1.10.27.jar | a0f0b759d895c15ceb3e3bcb5f3c2db7c582edf0 |
| LCHI | aom | 0.85 - MC 1.12.2 | Attack+on+Minecraft-0.85.jar | None |
| LCHI | atum | 2.0.18 | Atum-1.12.2-2.0.18.jar | None |
| LCHI | gorecore | 1.12.2-0.4.5 | avatarmod-1.5.17-alpha.jar | None |
| LCHI | avatarmod | 1.5.17-alpha | avatarmod-1.5.17-alpha.jar | None |
| LCHI | battletowers | 1.6.5 | BattleTowers-1.12.2 (1).jar | None |
| LCHI | betterbuilderswands | 0.11.1 | BetterBuildersWands-1.12-0.11.1.245+69d0d70.jar | None |
| LCHI | betterquesting | 3.5.329 | BetterQuesting-3.5.329.jar | None |
| LCHI | bibliocraft | 2.4.5 | BiblioCraft[v2.4.5][MC1.12.2].jar | None |
| LCHI | buildcraftlib | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcraftcore | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcraftbuilders | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcrafttransport | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcraftsilicon | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcraftcompat | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcraftenergy | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcraftfactory | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | buildcraftrobotics | 7.99.24.7 | buildcraft-all-7.99.24.7.jar | None |
| LCHI | ctm | MC1.12.2-1.0.2.31 | CTM-MC1.12.2-1.0.2.31.jar | None |
| LCHI | chisel | MC1.12.2-1.0.2.45 | Chisel-MC1.12.2-1.0.2.45.jar | None |
| LCHI | chunkpregenerator | 2.1 | Chunk+Pregenerator+V1.12-2.4E.jar | None |
| LCHI | sanlib | 1.5.1 | SanLib-1.12.2-1.5.1.jar | df48348748b5e141b1d118e2302a8d5be930b708 |
| LCHI | claysoldiers | 3.0.0-beta.2 | ClaySoldiersMod-1.12.2-3.0.0-beta.2.jar | None |
| LCHI | customnpcs | 1.12 | CustomNPCs_1.12.2-(05Jul20) (1).jar | None |
| LCHI | cxlibrary | 1.6.1 | cxlibrary-1.12.1-1.6.1.jar | None |
| LCHI | thedalekmod | (Update 59.1.0) | Dalek+Mod+-+Update+59.1.jar | None |
| LCHI | movingworld | 1.12-6.353 | movingworld-1.12-6.353-full.jar | None |
| LCHI | davincisvessels | @DVESSELSVER@ | davincisvessels-1.12-6.340-full.jar | None |
| LCHI | ptrmodellib | 1.0.4 | PTRLib-1.0.4 (1).jar | None |
| LCHI | props | 2.6.3 | Decocraft-2.6.3_1.12.2.jar | None |
| LCHI | divinerpg | 1.7.1 | DivineRPG-1.7.1.jar | None |
| LCHI | dragonmounts | 1.12.2-1.6.3 | DragonMounts2-1.12.2-1.6.3 (1).jar | None |
| LCHI | mjrlegendslib | 1.12.2-1.2.0 | MJRLegendsLib-1.12.2-1.2.0.jar | b02331787272ec3515ebe63ecdeea0d746653468 |
| LCHI | numina | 1.12.2-1.0.38 | Numina-1.12.2-1.0.38.jar | None |
| LCHI | thaumcraft | 6.1.BETA26 | Thaumcraft-1.12.2-6.1.BETA26.jar | None |
| LCHI | zollerngalaxy | 2.0.20 | ZollernGalaxy-1.12.2-v2.0.20.jar | None |
| LCHI | powersuits | 1.12.2-1.0.46 | ModularPowersuits-1.12.2-1.0.46.jar | None |
| LCHE | extraplanets | 1.12.2-0.7.0 | ExtraPlanets-1.12.2-0.7.0 (1).jar | b02331787272ec3515ebe63ecdeea0d746653468 |
| LCH | extra_spells | 1.2.0 | ExtraSpells-1.12.2-1.2.0.jar | None |
| LCH | mod_lavacow | 1.2.3 | Fish's+Undead+Rising-1.2.3.jar | None |
| LCH | foamfix | 0.10.10-1.12.2 | foamfix-0.10.10-1.12.2.jar | None |
| LCH | llibrary | 1.7.19 | llibrary-1.7.19-1.12.2 (2).jar | b9f30a813bee3b9dd5652c460310cfcd54f6b7ec |
| LCH | fossil | 8.0.4 | fossilsarcheology-8.0.4.jar | None |
| LCH | cfm | 6.3.1 | furniture-6.3.1-1.12.2 (1).jar | None |
| LCH | galaxyspace | 2.0.14 | GalaxySpace-1.12.2-2.0.14 (2).jar | None |
| LCH | generaldisasters | 1.0 | generaldisasters-1.0.jar | None |
| LCH | globe | 0.0.1 | Globe-1.12.2-0.0.1.jar | None |
| LCH | hammercore | 2.0.6.19 | HammerLib-1.12.2-2.0.6.19.jar | 9f5e2a811a8332a842b34f6967b7db0ac4f24856 |
| LCH | heroesarrival | 1.0.0 | Heroes+Arrival+1.2.1 (1).jar | None |
| LCH | speedsterheroes | 1.12.2-2.2.1 | SpeedsterHeroes-1.12.2-2.2.1.jar | None |
| LCH | lucraftcore | 1.12.2-2.4.10 | LucraftCore-1.12.2-2.4.10 (1).jar | None |
| LCH | heroesexpansion | 1.12.2-1.3.5 | HeroesExpansion-1.12.2-1.3.5.jar | None |
| LCH | howlingmoon | 0.9 | howlingmoon-1.12.2-0.9.jar | None |
| LCH | iceandfire | 1.9.1 | iceandfire-1.9.1-1.12.2.jar | None |
| LCH | jjmeteor | 1.0.10 | JJ+Meteor+1.12-1.12.2-v1.0.10.jar | None |
| LCH | lycanitesmobs | 2.0.7.2 - MC 1.12.2 | lycanitesmobs-1.12.2-2.0.7.2.jar | None |
| LCH | malisiscore | 1.12.2-6.5.1-SNAPSHOT | malisiscore-1.12.2-6.5.1.jar | None |
| LCH | malisisdoors | 1.12.2-7.3.0 | malisisdoors-1.12.2-7.3.0.jar | None |
| LCH | mca | 6.1.0 | MCA-1.12.2-6.1.0-universal (1).jar | None |
| LCH | mcanm | 2.7.5.156 | MCAnm-2.7.5.157+1.12.2.jar | None |
| LCH | mdxlib | 3.0.0.26 | mdxlib-3.0.0.26 (1).jar | None |
| LCH | worldedit | 6.1.10 | worldedit-forge-mc1.12.2-6.1.10-dist (1).jar | None |
| LCH | mhfc | 1.4.10 | mhfc-1.4.10-1.12.2.jar | None |
| LCH | moreplanets | 2.0.24 | More-Planets-1.12.2-2.0.24-GC251 (2).jar | b3468b224a74e296555ad7efeb35f482e6f445de |
| LCH | moreplanetsextras | 1.12.2-1.0 | MorePlanetsExtras-1.12.2-1.0 (1).jar | None |
| LCH | mowziesmobs | 1.5.8 | mowziesmobs-1.5.8.jar | None |
| LCH | multipagechest | 1.9.1 | MultiPageChest-1.12-1.9.1.jar | None |
| LCH | mutantbeasts | 1.12.2-0.6.2 | MutantBeasts-1.12.2-0.6.2.jar | 25e0dcff5b5a7325d7c28898af41ff8b0ba41b77 |
| LCH | my_hero_academia | 1.0.0 | My+Hero+Alpha+0.1.3.1+(Bugfix) (2).jar | None |
| LCH | mystcraft | 0.13.7.06 | mystcraft-1.12.2-0.13.7.06.jar | None |
| LCH | neid | 1.5.4.4 | NotEnoughIDs-1.5.4.4.jar | None |
| LCH | nuclearcraft | 2.18y | NuclearCraft-2.18y-1.12.2.jar | None |
| LCH | opencomputers | 1.7.5.192 | OpenComputers-MC1.12.2-1.7.5.192.jar | None |
| LCH | sanplayermodel | 1.1.1 | SanLib-1.12.2-1.5.1.jar | None |
| LCH | flammpfeil.slashblade | mc1.12-r32 | SlashBlade-Mod-1.12.2.jar | None |
| LCH | surge | 2.0.77 | Surge-1.12.2-2.0.77.jar | d476d1b22b218a10d845928d1665d45fce301b27 |
| LCH | techguns | 2.0.2.0 | techguns-1.12.2-2.0.2.0_pre3.2.jar | None |
| LCH | twilightforest | 3.10.1013 | twilightforest-1.12.2-3.10.1013-universal.jar | None |
| LCH | valkyrienskies | 1.0-alpha-1 | ValkyrienSkies-1.12.2-1.0-alpha-1.jar | None |
| LCH | vs_open_computers | 1.0-alpha-1 | ValkyrienSkies-1.12.2-1.0-alpha-1.jar | None |
| LCH | vs_world | 1.0-alpha-1 | ValkyrienSkies-1.12.2-1.0-alpha-1.jar | None |
| LCH | vs_control | 1.0-alpha-1 | ValkyrienSkies-1.12.2-1.0-alpha-1.jar | None |
| LCH | vampirism | 1.6.2 | Vampirism-1.12.2-1.6.2 (1).jar | None |
| LCH | teamlapen-lib | 1.6.2 | Vampirism-1.12.2-1.6.2 (1).jar | None |
| LCH | vc | 5.9.16 | ViesCraft-1.12.2-5.9.16.jar | None |
| LCH | xaerominimap | 20.27.2 | Xaeros_Minimap_20.27.2_Forge_1.12.jar | None |
| LCH | xaeroworldmap | 1.11.0 | XaerosWorldMap_1.11.0_Forge_1.12.jar | None |
| LCH | betteranimalsplus | 9.0.1 | betteranimalsplus-1.12.2-9.0.1.jar | None |
| LCH | exoplanets | 0.2.0 | Interstellar-Exoplanets-1.12.2-0.2.0-dev.22.jar | 9849375f22c1477466799effce3d8a566ae781cf |
| LCH | rebornmod | 1.0-1.12.2 | JWR-1.12.2-1.0.jar | None |
| LCH | structurize | 1.12.2-0.10.277-RELEASE | structurize-1.12.2-0.10.277-RELEASE.jar | None |
| LCH | minecolonies | 1.12.2-0.11.811-BETA | minecolonies-1.12.2-0.11.811-BETA-universal.jar | None |
| LCH | thebetweenlands | 3.6.2 | TheBetweenlands-3.6.2-universal.jar | 38067d6878811efb38b6a045521cfd80b9b60b38 |
Loaded coremods (and transformers):
TransformerLoader (OpenComputers-MC1.12.2-1.7.5.192.jar)
li.cil.oc.common.asm.ClassTransformer
FMLModule (mdxlib-3.0.0.26 (1).jar)
com.asx.mdx.AccessTransformer
MovingWorldCore (movingworld-1.12-6.353-full.jar)
MicdoodlePlugin (MicdoodleCore-1.12.2-4.0.2.280.jar)
micdoodle8.mods.miccore.MicdoodleTransformer
XaeroWorldMapPlugin (XaerosWorldMap_1.11.0_Forge_1.12.jar)
xaero.map.core.transformer.ChunkTransformer
xaero.map.core.transformer.NetHandlerPlayClientTransformer
xaero.map.core.transformer.EntityPlayerTransformer
xaero.map.core.transformer.AbstractClientPlayerTransformer
xaero.map.core.transformer.WorldClientTransformer
xaero.map.core.transformer.PlayerListTransformer
CXLibraryCore (cxlibrary-1.12.1-1.6.1.jar)
cubex2.cxlibrary.CoreModTransformer
LucraftCoreCoreMod (LucraftCore-1.12.2-2.4.10 (1).jar)
lucraft.mods.lucraftcore.core.LCTransformer
HCASM (HammerLib-1.12.2-2.0.6.19.jar)
com.zeitheron.hammercore.asm.HammerCoreTransformer
iceandfire (iceandfire-1.9.1-1.12.2.jar)
com.github.alexthe666.iceandfire.patcher.IceAndFireRuntimePatcher
CTMCorePlugin (CTM-MC1.12.2-1.0.2.31.jar)
team.chisel.ctm.client.asm.CTMTransformer
Plugin (NotEnoughIDs-1.5.4.4.jar)
ru.fewizz.neid.asm.Transformer
llibrary (llibrary-core-1.0.11-1.12.2.jar)
net.ilexiconn.llibrary.server.core.plugin.LLibraryTransformer
net.ilexiconn.llibrary.server.core.patcher.LLibraryRuntimePatcher
AstralCore (astralsorcery-1.12.2-1.10.27.jar)
TheBetweenlandsLoadingPlugin (TheBetweenlands-3.6.2-core.jar)
thebetweenlands.core.TheBetweenlandsClassTransformer
Do not report to Forge! (If you haven't disabled the FoamFix coremod, try disabling it in the config! Note that this bit of text will still appear.) (foamfix-0.10.10-1.12.2.jar)
pl.asie.foamfix.coremod.FoamFixTransformer
MixinLoaderForge (ValkyrienSkies-1.12.2-1.0-alpha-1.jar)
Techguns Core (techguns-1.12.2-2.0.2.0_pre3.2.jar)
techguns.core.TechgunsASMTransformer
CorePlugin (AcademyCraft-1.1.3.jar)
cn.lambdalib2.render.mc.PipelineTransformer
cn.lambdalib2.registry.impl.RegistryTransformer
MalisisCorePlugin (malisiscore-1.12.2-6.5.1.jar)
SurgeLoadingPlugin (Surge-1.12.2-2.0.77.jar)
XaeroMinimapPlugin (Xaeros_Minimap_20.27.2_Forge_1.12.jar)
xaero.common.core.transformer.ChunkTransformer
xaero.common.core.transformer.NetHandlerPlayClientTransformer
xaero.common.core.transformer.EntityPlayerTransformer
xaero.common.core.transformer.AbstractClientPlayerTransformer
xaero.common.core.transformer.WorldClientTransformer
xaero.common.core.transformer.EntityPlayerSPTransformer
xaero.common.core.transformer.PlayerListTransformer
GSHooksLoader (GalaxySpace-1.12.2-2.0.14 (2).jar)
galaxyspace.core.hooklib.minecraft.PrimaryClassTransformer
GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 430.97' Renderer: 'GeForce GTX 1050/PCIe/SSE2'
HammerCore Debug Information:
Dependent Mods: None.
OptiFine Version: OptiFine_1.12.2_HD_U_F5
OptiFine Build: 20191204-141934
Render Distance Chunks: 12
Mipmaps: 4
Anisotropic Filtering: 1
Antialiasing: 0
Multitexture: false
Shaders: null
OpenGlVersion: 4.6.0 NVIDIA 430.97
OpenGlRenderer: GeForce GTX 1050/PCIe/SSE2
OpenGlVendor: NVIDIA Corporation
CpuCount: 12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}