#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[.*?(?P<parts>\d{1,3}\/\d{1,3}) \] \- "(?!.*\s((S\d{1,2}E\d{1,2})|(S\d{1,2}))\s)(?P<name>.*?)\.(vol|rar|par|sfv|nfo|nzb)"
Local $sString = "I want the regex to match results like" & @CRLF & _
"" & @CRLF & _
"[ TrollHD ] - [ 002/124 ] - "2015 Dream Concert 1080p Netflix WEBRip DD+ 2.0 x264-TrollHD.part001.rar" yEnc (1/164)" & @CRLF & _
"" & @CRLF & _
"but skip results like" & @CRLF & _
"" & @CRLF & _
"[ TrollHD ] - [ 04/30 ] - "Chelsea S02E05 1080p Netflix WEBRip DD+ 2.0 x264-TrollHD.part03.rar" yEnc (1/164)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")