use strict;
my $str = '(Name) + modifier1 modifier2 +
Some (ideas) sentences, words?! and ellipses…
(Name) + modifier1 modifier2 +
Some (ideas) sentences, words?! and ellipses…
Some (ideas) sentences, words?! and ellipses…
';
my $regex = qr/((?:^|\n)\s*\((?<name>[^)]+)\)\s*\+\s*(?<modifiers>[^+]*)\s*\+\n)?\s*(?<head>[^(]*)\((?<ideas>[^)]*)\)\s*(?<tail>[^\n]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}