const regex = /(?<=Received: from ).*(?= by)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Received: from ).*(?= by)', 'g')
const str = `Dec 25 21:44:10 ra-mx amavis[69766]: (69766-04) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T202928-69766-zqjUPXL8: <notification+kr4keges24xr@facebookmail.com> -> <sto@kingkong.network> SIZE=21892 BODY=8BITMIME Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <sto@kingkong.network>; Sun, 25 Dec 2016 21:44:10 +0100 (CET)
Dec 25 21:47:27 ra-mx amavis[67599]: (67599-13) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T182139-67599-Iw5AO2Ei: <> -> <bounce@espeurope.net> SIZE=25924 Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <bounce@espeurope.net>; Sun, 25 Dec 2016 21:47:27 +0100 (CET)
Dec 25 21:49:08 ra-mx amavis[67599]: (67599-14) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T182139-67599-Iw5AO2Ei: <> -> <noreply@espeurope.net> SIZE=7152 Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <noreply@espeurope.net>; Sun, 25 Dec 2016 21:49:08 +0100 (CET)
Dec 25 22:12:07 ra-mx amavis[69766]: (69766-05) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T202928-69766-zqjUPXL8: <notification+kr4keges24xr@facebookmail.com> -> <sto@kingkong.network> SIZE=12043 BODY=8BITMIME Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <sto@kingkong.network>; Sun, 25 Dec 2016 22:12:07 +0100 (CET)
Dec 25 22:24:12 ra-mx amavis[67599]: (67599-15) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T182139-67599-Iw5AO2Ei: <kh004r5582@blueyonder.co.uk> -> <bounce@espeurope.net> SIZE=5022 Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <bounce@espeurope.net>; Sun, 25 Dec 2016 22:24:12 +0100 (CET)
Dec 25 22:43:12 ra-mx amavis[69766]: (69766-06) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T202928-69766-zqjUPXL8: <> -> <noreply@espeurope.net> SIZE=7185 Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <noreply@espeurope.net>; Sun, 25 Dec 2016 22:43:12 +0100 (CET)
Dec 25 23:35:30 ra-mx amavis[67599]: (67599-16) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T182139-67599-Iw5AO2Ei: <> -> <bounce@espeurope.net> SIZE=3752 BODY=8BITMIME ENVID=0OIR003T4IP20A10@etrn.telekom.sk Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <bounce@espeurope.net>; Sun, 25 Dec 2016 23:35:30 +0100 (CET)
Dec 25 23:35:35 ra-mx amavis[69766]: (69766-07) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T202928-69766-zqjUPXL8: <> -> <bounce@espeurope.net> SIZE=3751 BODY=8BITMIME ENVID=0OIR003U4IP80A10@etrn.telekom.sk Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <bounce@espeurope.net>; Sun, 25 Dec 2016 23:35:35 +0100 (CET)
Dec 25 23:37:53 ra-mx amavis[69766]: (69766-08) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T202928-69766-zqjUPXL8: <notification+kr4keges24xr@facebookmail.com> -> <sto@kingkong.network> SIZE=17322 BODY=8BITMIME Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <sto@kingkong.network>; Sun, 25 Dec 2016 23:37:53 +0100 (CET)
Dec 25 23:39:12 ra-mx amavis[69766]: (69766-09) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T202928-69766-zqjUPXL8: <maja.wahlen@sunrise.ch> -> <bounce@espeurope.net> SIZE=7695 BODY=7BIT Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <bounce@espeurope.net>; Sun, 25 Dec 2016 23:39:12 +0100 (CET)
Dec 25 23:44:23 ra-mx amavis[69766]: (69766-10) ESMTP [193.203.199.10]:10024 /var/amavis/tmp/amavis-20161225T202928-69766-zqjUPXL8: <> -> <noreply@espeurope.net> SIZE=7138 Received: from ra-mx.espeurope.net ([193.203.199.10]) by ra-mx (ra-mx.espeurope.net [193.203.199.10]) (amavisd-new, port 10024) with ESMTP for <noreply@espeurope.net>; Sun, 25 Dec 2016 23:44:23 +0100 (CET)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}