$re = '/<yt-formatted-string id=\"subscriber-count\" [^>]+>(.*?)<\/yt-formatted-string>/m';
$str = ' <yt-formatted-string id="subscriber-count" class="style-scope ytd-c4-tabbed-header-renderer">1,94 mln subskrypcji</yt-formatted-string>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);