#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*May"
Local $sString = "Xxxxx_xxxxx_PKN_Trueview_24th MayComedy Movie Fans18-24 " & @CRLF & _
"Xxxxx_xxxxx_PKN_Trueview_24th MaySouth Asian Film Fans18-24 " & @CRLF & _
"Xxxxx_xxxxx_PKN_Trueview_24th MayCricket Enthusiasts18-24 " & @CRLF & _
"Xxxxx_xxxxx_PKN_Trueview_24th MayMotorcycle Enthusiasts18-24 "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)