$re = '/^(?=.*[0])^(?=.*[9])(?=.*[0-9]).{10,10}$/';
$str = '0988123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);