import re
regex = re.compile(r"Content-ID:[\s\S].+?c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org[\s\S]*?>([\s\S]*?)--uuid", flags=re.MULTILINE)
test_str = ("HTTP/1.1 200 OK\n"
"Date: ...\n"
"Server: .....\n"
"Set-Cookie: ....; Path=/; HttpOnly\n"
"Set-Cookie: ...; Path=/; HttpOnly\n"
"Content-Type: multipart/related; type=\"application/xop+xml\"; boundary=\"uuid:0f7fa750-c317-4039-897a-a90685b00d29\"; start=\"<...>\"; start-info=\"text/xml\"\n"
"Keep-Alive: timeout=5, max=99\n"
"Connection: Keep-Alive\n"
"Transfer-Encoding: chunked\n\n"
"--uuid:0f7fa750-c317-4039-897a-a90685b00d29\n"
"Content-Type: application/xop+xml; charset=UTF-8; type=\"text/xml\";\n"
"Content-Transfer-Encoding: binary\n"
"Content-ID: <root.message@cxf.apache.org>\n\n"
"<soap:Envelope xmlns:soap=\"http://schemas.xmlsoap.org/soap/envelope/\"><soap:Body><ns2:downloadAttachResponse xmlns:ns2=\"http://..../\"><return><errStr></errStr><result>0</result><contentFile><xop:Include xmlns:xop=\"http://www.w3.org/2004/08/xop/include\" href=\"cid:c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org\"/></contentFile></return></ns2:downloadAttachResponse></soap:Body></soap:Envelope>\n"
"--uuid:0f7fa750-c317-4039-897a-a90685b00d29\n"
"Content-Type: application/octet-stream\n"
"Content-Transfer-Encoding: binary\n"
"Content-ID: <c4d149e6-3f6a-4aa8-bd07-244c92bdc262-2@cxf.apache.org>\n\n"
"%PDF-1.4\n"
"...\n\n"
" LOTS OF BINARY CODE HERE FOR THE PDF\n\n"
"--uuid:0f7fa750-c317-4039-897a-a90685b00d29--\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")