import re
regex = re.compile(r"^(.*)\.(xls|xlsx|csv|tsv|odt)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("cXdyORNyNzA0NDEzMjA_-?''9NmM_mJSIiNTM2FjUyeHd4fg.XLS\n"
"cXdyORNyNzA0NDEzMjA_-?''9NmM_mJSIiNTM2FjUyeHd4fg.csv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")