const regex = /s:(\d+):\\\"[^\\]*(?:\\(?!\")[^\\]*)*?(https?:\/\/)?example\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s:(\\d+):\\\\\\"[^\\\\]*(?:\\\\(?!\\")[^\\\\]*)*?(https?:\\\/\\\/)?example\\.com', 'gm')
const str = `a:5:{s:5:\\"test1\\";s:35:\\"example.com\\";s:5:\\"test2\\";s:26:\\"foo <a href="http://example.com/bar"></a>\\";s:11:\\"submit_data\\"}
a:5:{s:5:\\"test1\\";s:35:\\"example.com\\";s:5:\\"test2\\";s:26:\\"foo http://example.com/bar\\";s:11:\\"submit_data\\"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}