re = /^\s*insert(?:\s+into)?\s+(?<TableName>\[.*?\]|[^ (]+)\s*\((?<Columns>.+?)\)/im
str = 'insert into [SomeTable]([Run ID]) values (something, something)
insert [SomeTable]([Run ID]) values (something, something)
insert into [SomeTable]([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert SomeTable([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert [Some Table]([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert into [Some Table] ([Run ID]) values (something, something)
insert [Some Table] ([Run ID]) values (something, something)
insert into [Some Table] ( [Run ID],) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].TestOdbcReadAndWriteTo([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert nGineUnitTests.dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ( [Run ID],) values (something, something)
"This is not an insert statement insert into [dbo].[DoNotAllowNullsString]([Col_umn1]) values (?)"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end