$re = '/^adress=([a-z.]+?)\s*port=([0-9]{3})/';
$str = 'adress=ad.test.com
port=768';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);