#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\d,]+|,+\D|\D,+|\d+,\d{3,}|\d{3,}(?:,\d+)?|^,|,$"
Local $sString = "Of course, 22d,3 equals 22,3, or A equals (empty string), 12 equals 12, need to remove anything that's not a number and my separator for float is ," & @CRLF & _
"" & @CRLF & _
"This is a 12 test with 12,34 digits and 123.23 or 123,1 or 123,12 or123,123 and 1234,1 but not 1,234 .html" & @CRLF & _
"" & @CRLF & _
"test-test" & @CRLF & _
"34,344" & @CRLF & _
"34,34" & @CRLF & _
"34,1" & @CRLF & _
"34.1" & @CRLF & _
"1" & @CRLF & _
"1,1" & @CRLF & _
"1,12" & @CRLF & _
"12" & @CRLF & _
"100000" & @CRLF & _
"" & @CRLF & _
"This is a ,comma here and ,,,,,3where ," & @CRLF & _
",," & @CRLF & _
"," & @CRLF & _
"This is , a a test 10,2333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")