# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<\w+\s*[^>]*)\s(?!href|title|alt)[\w\-\d]+\s*=\s*(?:(['\"]).*?\2|\w+)"
test_str = ("<p></p><p>\n"
"Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. \n"
"</p>\n\n"
"<p> </p>\n"
"href=\"test\" Test\n"
"<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>\n"
"<a href=\"www.google.de\">Test</a>\n"
"<a href= 'www.google.de' onmouseover =\"alert('Test2')\" >Test2</a>\n"
"<b></b>\n"
"<ul>\n"
"<li>\n"
"Element 1\n"
"</li>\n"
"<li onmouseover= 'alert(\"Test this\")'>\n"
"Element 2\n"
"</li>\n"
"</ul>\n"
"<ol>\n"
"</ol>\n"
"<script>alert(\"Test\");</script>\n"
"<p title=\"test\"> </p>\n"
"<p onmouseover=\"alert('test')\">\n"
"<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>\n\n"
"<p onmouseover=\"test\" title=\"test\"> </p>\n\n"
"<p>At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p><p></p>\n"
" ")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.