package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z^_]`)
var str = `CAPITAL
small
0digit
#symbol
_oops
^lol
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}