$re = '@<div class="try">text</div>@m';
$str = '<div class="try">text</div>
<div>text</div>
text
<span>text</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);