package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Ha){3,5}`)
var str = `HaHaHaHaHa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}