$re = '/([^)]*)/m';
$str = '(2+4)
(2+1)(4-3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);