package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\$+[^\n$]+\$+)`)
var str = `$\begin{bmatrix} k & k & k \end{bmatrix}^T$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}