import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SRR([0-9]+)([\\.])([0-9]+)([\\s]+)([A-Z]+)";
final String string = " sequence_id cdr3_aa\n"
+ "0 SRR11610498.829751 AKDLGPDAGYTVFNDYFDN\n"
+ "1 SRR11610498.853725 AKDLGPDAGYTVFNDYFDN\n"
+ "2 SRR11610498.856922 AKDLGPDAGYTVFNHYFDN\n"
+ "3 SRR11610498.861591 AKDLGPDAGYTVFNDYFDN\n"
+ "4 SRR11610498.909314 AKDLGPDAGYTVFNDYFDN\n"
+ "5 SRR11610498.915768 AKDLGPDAGYTVFNDYFDN\n"
+ "6 SRR11610498.922245 ARGGLVVVDSFDY\n"
+ "7 SRR11610498.1017490 ASDLSYASSWLHYFDV\n"
+ "8 SRR11610498.1022079 ARLRFDNGALYFDY\n"
+ "9 SRR11610498.1037667 ASSAPPSGFNWFDP\n"
+ "10 SRR11610498.1111232 AKGPQIVATTTDNLEV\n"
+ "11 SRR11610498.1183596 AKDLGPDAGYTVFNDYFDN \n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}