re = /(?s) *(<[^>]*>)/m
str = '
<div style={{ padding: \'10px 30px\', backgroundColor: \'tomato\' }}>
<h2>Try making this heading have the color green</h2>
</div>
<Box>
<Heading>Here\'s a JSX block</Heading>
<Text>It\'s pretty neat</Text>
</Box>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end