#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\D)[56]\d{5,6}(?!\d)"
Local $sString = "5494398 70008 'order # 5494398 Product#: 70008" & @CRLF & _
"5001447452 ' should be ignored" & @CRLF & _
"6415366 OSW SHIP 70052 'order # 6415366 Product#: 70052" & @CRLF & _
"6567598y7058 Nov 20 'order # 6567598 Product#: 7058" & @CRLF & _
"OSW SHIP 70054 RH STRONGBACKS 'order # N/A Product#: 70054" & @CRLF & _
"OSW HS 70052 70053 'order # N/A Product#: 70008" & @CRLF & _
"6511534 04450 'order # 6511534 Product#:either 04450 or 0445 (this is only case)" & @CRLF & _
"6511538 0046 'order # 6511538 Product#: 0046" & @CRLF & _
"0046 6387125 'order # 6387125 Product#: 0046" & @CRLF & _
"OSW 70032 'order # N/A Product#: 70032" & @CRLF & _
"OSW HEX Blots 046 047 048 049 'order # N/A Product#: 064 & 047 & 048 & 049 (4 matches)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")