$re = '/^\d+(?:\s*,\s*\d+)*$/m';
$str = '1, 434, 634, 8
1 2 4
1, 2, 4,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);